medium5.4
CVE-2023-0109
Stored XSS using two files in usememos/memos
Impact
A stored cross-site scripting (XSS) vulnerability was discovered in usememos/memos version 0.9.1. This vulnerability allows an attacker to upload a JavaScript file containing a malicious script and reference it in an HTML file. When the HTML file is accessed, the malicious script is executed. This can lead to the theft of sensitive information, such as login credentials, from users visiting the affected website. The issue has been fixed in version 0.10.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/usememos/memos | < 0.10.0 | 0.10.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Usememos | Memos | Version 0.9.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/usememos/memos/commit/46c13a4b7f675b92d297df6dabb4441f13c7cd9c
- https://huntr.com/bounties/1899ffb2-ce1e-4dc0-af96-972612190f6e
- https://github.com/advisories/GHSA-5r2g-59px-3q9w
- https://nvd.nist.gov/vuln/detail/CVE-2023-0109
- https://pkg.go.dev/vuln/GO-2024-3274