NetSight
high8.4

CVE-2023-0163

convict vulnerable to Prototype Pollution

Impact

### Impact * An attacker can inject attributes that are used in other components * An attacker can override existing attributes with ones that have incompatible type, which may lead to a crash. The main use case of Convict is for handling server-side configurations written by the admins owning the servers, and not random users. So it's unlikely that an admin would deliberately sabotage their own server. Still a situation can happen where an admin not knowledgeable about JavaScript could be tricked by an attacker into writing the malicious JavaScript code into some config files. ### Patches The problem is patched in `convict@6.2.4`. Users should upgrade to `convict@6.2.4`. ### Workarounds No way for users to fix or remediate the vulnerability without upgrading ### References https://github.com/mozilla/node-convict/issues/410

Affected packages

EcosystemPackageAffectedFixed in
npmconvict< 6.2.46.2.4

Affected products

VendorProductAffected versions
MozillaConvict
before 6.2.4

Weakness classification

References