NetSight
medium4.2

CVE-2023-0475

Data Amplification in HashiCorp go-getter

Impact

HashiCorp go-getter up to 1.6.2 and 2.1.1 is vulnerable to decompression bombs. Fixed in 1.7.0 and 2.2.0.

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/hashicorp/go-getter< 1.7.01.7.0
gogithub.com/hashicorp/go-getter/v2>= 2.0.0, < 2.2.02.2.0

Affected products

VendorProductAffected versions
HashicorpGo-Getter
through 1.6.2
Version 2.1.1

Weakness classification

References