CVE-2023-0594
Grafana vulnerable to Cross-site Scripting
Impact
Grafana is an open-source platform for monitoring and observability. Starting with the 7.0 branch, Grafana had a stored XSS vulnerability in the trace view visualization. The stored XSS vulnerability was possible due the value of a span's attributes/resources were not properly sanitized and this will be rendered when the span's attributes/resources are expanded. An attacker needs to have the Editor role in order to change the value of a trace view visualization to contain JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. Users may upgrade to version 8.5.21, 9.2.13 and 9.3.8 to receive a fix.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/grafana/grafana | >= 7.0.0, < 8.5.21 | 8.5.21 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Grafana | Grafana | from 7.0.0 before 8.5.21 from 9.2.0 before 9.2.13 from 9.3.0 before 9.3.8 |