high8.1
CVE-2023-0870
OpenNMS Meridian and Horizon vulnerable to Cross-Site Request Forgery
Impact
A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.opennms:opennms-webapp | < 31.0.6 | 31.0.6 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Opennms | Horizon | before 31.0.6 |
| Opennms | Meridian | from 2020.1.0 before 2020.1.33 from 2021.1.0 before 2021.1.25 from 2022.1.0 before 2022.1.14 Version 2023.1.0 |