NetSight
high8.2

CVE-2023-0872

OpenNMS privilege elevation vulnerability

Impact

The Horizon REST API includes a users endpoint in OpenNMS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.opennms:opennms-webapp-rest>= 31.0.8, < 32.0.232.0.2

Affected products

VendorProductAffected versions
OpennmsHorizon
from 31.0.8 before 32.0.2
OpennmsMeridian
from 2020.0.0 through 2020.1.37
from 2021.0.0 through 2021.1.29
from 2022.0.0 through 2022.1.18
from 2023.0.0 through 2023.1.5

Weakness classification

References