NetSight
low3.5

CVE-2023-1001

vxe-table Cross-site Scripting vulnerability

Impact

A vulnerability, which was classified as problematic, has been found in xuliangzhan vxe-table up to 3.7.9. This issue affects the function export of the file packages/textarea/src/textarea.js of the component vxe-textarea. The manipulation of the argument inputValue leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.7.10 is able to address this issue. The patch is named d70b0e089740b65a22c89c106ebc4627ac48a22d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-266123.

Affected packages

EcosystemPackageAffectedFixed in
npmvxe-table< 3.7.103.7.10

Affected products

ProductAffected versions
Xuliangzhan Vxe-Table
before 3.7.9.

Versions were read from the advisory text. No structured product data has been published for this record yet.

Weakness classification

References