NetSight
critical9.8

CVE-2023-20873

Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry

Impact

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.springframework.boot:spring-boot-actuator-autoconfigure>= 3.0.0, < 3.0.63.0.6

Affected products

VendorProductAffected versions
VmwareSpring Boot
before 2.5.15
from 2.6.0 before 2.6.14
from 2.7.0 before 2.7.11
from 3.0.0 before 3.0.6

References