critical9.8
CVE-2023-22727
CakePHP Database\\Query::offset() and limit() methods are vulnerable to SQL injection
Impact
### Impact The `Cake\Database\Query::limit()` and `Cake\Database\Query::offset()` methods are vulnerable to SQL injection if passed un-sanitized user request data. ### Patches This issue has been fixed in 4.2.12, 4.3.11, 4.4.10 ### Workarounds Using CakePHP's Pagination library will mitigate this issue, as will validating or casting parameters to these methods. ### References https://bakery.cakephp.org/2023/01/06/cakephp_4211_4311_4410_released.html
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | cakephp/cakephp | >= 4.2.0, < 4.2.12 | 4.2.12 |
| composer | cakephp/database | >= 4.2.0, < 4.2.12 | 4.2.12 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Cakephp | Cakephp | from 4.2.0 before 4.2.12 from 4.3.0 before 4.3.11 from 4.4.0 before 4.4.10 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://bakery.cakephp.org/2023/01/06/cakephp_4211_4311_4410_released.html
- https://github.com/cakephp/cakephp/commit/3f463e7084b5a15e67205ced3a622577cca7a239
- https://github.com/cakephp/cakephp/security/advisories/GHSA-6g8q-qfpv-57wp
- https://github.com/advisories/GHSA-6g8q-qfpv-57wp
- https://nvd.nist.gov/vuln/detail/CVE-2023-22727