high8.6
CVE-2023-23621
Discourse is an open-source discussion platform.
Impact
Discourse is an open-source discussion platform. Prior to version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches, a malicious user can cause a regular expression denial of service using a carefully crafted user agent. This issue is patched in version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Discourse | Discourse | before 3.0.1 Versions 1.1.0, 1.2.0, 1.3.0, 1.4.0, 1.5.0 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/discourse/discourse/commit/6d92c3cbdac431db99a450f360a3048bb3aaf458
- https://github.com/discourse/discourse/pull/20002
- https://github.com/discourse/discourse/security/advisories/GHSA-mrfp-54hf-jrcv
- https://github.com/discourse/discourse/commit/6d92c3cbdac431db99a450f360a3048bb3aaf458
- https://github.com/discourse/discourse/pull/20002
- https://github.com/discourse/discourse/security/advisories/GHSA-mrfp-54hf-jrcv