critical9.8
CVE-2023-25135
vBulletin before 5.6.9 PL1 allows an unauthenticated remote attacker to execute arbitrary code via a crafted HTTP request that triggers deserialization.
Impact
vBulletin before 5.6.9 PL1 allows an unauthenticated remote attacker to execute arbitrary code via a crafted HTTP request that triggers deserialization. This occurs because verify_serialized checks that a value is serialized by calling unserialize and then checking for errors. The fixed versions are 5.6.7 PL1, 5.6.8 PL1, and 5.6.9 PL1.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Vbulletin | Vbulletin | Versions 5.6.7, 5.6.8, 5.6.9 |
Weakness classification
References
- NVD record
- CVE.org record
- https://forum.vbulletin.com/forum/vbulletin-announcements/vbulletin-announcements_aa/4473890-vbulletin-5-6-9-security-patch
- https://www.ambionics.io/blog/vbulletin-unserializable-but-unreachable
- https://forum.vbulletin.com/forum/vbulletin-announcements/vbulletin-announcements_aa/4473890-vbulletin-5-6-9-security-patch
- https://www.ambionics.io/blog/vbulletin-unserializable-but-unreachable