NetSight
high7.5

CVE-2023-25156

No protection against brute-force attacks on login page

Impact

### Impact Previous versions of Kiwi TCMS do not impose rate limits which makes it easier to attempt brute-force attacks against the login page. ### Patches Users should upgrade to v12.0 or later. ### Workarounds Users may install and configure a rate-limiting proxy in front of Kiwi TCMS. For example nginx. ### References [Disclosed by spyata](https://huntr.dev/bounties/2b1a9be9-45e9-490b-8de0-26a492e79795/)

Affected packages

EcosystemPackageAffectedFixed in
pipkiwitcms< 12.012.0

Affected products

VendorProductAffected versions
KiwitcmsKiwi Tcms
before 12.0

Weakness classification

References