high8.6
CVE-2023-25164
Sensitive Information leak via Script File in TinaCMS
Impact
### Impact Sensitive Information leaked via script File in TinaCMS. Sites building with @tinacms/cli >= 1.0.0 && < 1.0.9 that store sensitive values in process.env var are impacted. If you're on a version prior to 1.0.0 this vulnerability does not affect you. If your Tina-enabled website has sensitive credentials stored as environment variables (eg. Algolia API keys) you should rotate those keys immediately. ### Patches This issue has been patched in @tinacms/cli@1.0.9 ### Workarounds Upgrading, and rotating secure & exposed keys is required for the proper fix. ### References https://github.com/tinacms/tinacms/pull/3584
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | @tinacms/cli | >= 1.0.0, < 1.0.9 | 1.0.9 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Ssw | Tinacms\/Cli | from 1.0.0 before 1.0.9 |