critical9.0
CVE-2023-26482
Nextcloud server is an open source home cloud implementation.
Impact
Nextcloud server is an open source home cloud implementation. In affected versions a missing scope validation allowed users to create workflows which are designed to be only available for administrators. Some workflows are designed to be RCE by invoking defined scripts, in order to generate PDFs, invoking webhooks or running scripts on the server. Due to this combination depending on the available apps the issue can result in a RCE at the end. It is recommended that the Nextcloud Server is upgraded to 24.0.10 or 25.0.4. Users unable to upgrade should disable app `workflow_scripts` and `workflow_pdf_converter` as a mitigation.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Nextcloud | Nextcloud Server | from 18.0.0 before 20.0.14.12 from 21.0.0 before 21.0.9.10 from 22.0.0 before 22.2.10.10 from 23.0.0 before 23.0.12.5 from 24.0.0 before 24.0.10 from 25.0.0 before 25.0.4 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-h3c9-cmh8-7qpj
- https://github.com/nextcloud/server/commit/5a06b50b10cc9278bbe68bbf897a0c4aeb0c4e60
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-h3c9-cmh8-7qpj
- https://github.com/nextcloud/server/commit/5a06b50b10cc9278bbe68bbf897a0c4aeb0c4e60