high7.5
CVE-2023-27560
phpseclib Infinite Loop vulnerability
Impact
Math/PrimeField.php in phpseclib has an infinite loop with composite primefields. This vulnerability was introduced in version 3.0.0, and has been patched in 3.0.19. The CVE for this issue originally identified the the vulnerable version as 2.x, however, the vulnerable functionality was not introduced until version 3.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | phpseclib/phpseclib | >= 3.0.0, < 3.0.19 | 3.0.19 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Phpseclib | Phpseclib | from 3.0.0 before 3.0.19 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/phpseclib/phpseclib/commit/6298d1cd55c3ffa44533bd41906caec246b60440
- https://github.com/phpseclib/phpseclib/releases/tag/3.0.19
- https://github.com/advisories/GHSA-hm7p-r324-hhf3
- https://nvd.nist.gov/vuln/detail/CVE-2023-27560
- https://github.com/phpseclib/phpseclib/commit/6298d1cd55c3ffa44533bd41906caec246b60440#commitcomment-103226722
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpseclib/phpseclib/CVE-2023-27560.yaml