high7.5
CVE-2023-27891
Insufficient Session Expiration in pretix
Impact
rami.io pretix before 4.17.1 allows OAuth application authorization from a logged-out session. The fixed versions are 4.15.1, 4.16.1, and 4.17.1.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | pretix | >= 4.17.0, < 4.17.1 | 4.17.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Rami | Pretix | from 1.16.0 before 4.15.1 Versions 4.16.0, 4.17.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://pretix.eu/about/en/blog/20230306-release-4171/
- https://github.com/advisories/GHSA-r76w-3wwq-jv6v
- https://nvd.nist.gov/vuln/detail/CVE-2023-27891
- https://github.com/pypa/advisory-database/tree/main/vulns/pretix/PYSEC-2023-42.yaml
- https://pretix.eu/about/en/blog/20230306-release-4171