critical9.6
CVE-2023-27905
Cross site scripting vulnerability in update-center2
Impact
Jenkins update-center2 3.13 and 3.14 renders the required Jenkins core version on plugin download index pages without sanitization, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide a plugin for hosting.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.jenkins-ci:update-center2 | >= 3.13, < 3.15 | 3.15 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Jenkins | Update-Center2 | Versions 3.13, 3.14 |