high7.5
CVE-2023-28867
GraphQL Java vulnerable to stack consumption
Impact
In GraphQL Java (aka graphql-java) before 20.1, an attacker can send a crafted GraphQL query that causes stack consumption. The fixed versions are 20.1, 19.4, 18.4, 17.5, and 0.0.0-2023-03-20T01-49-44-80e3135.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | com.graphql-java:graphql-java | < 0.0.0-2023-03-20T01-49-44-80e3135 | 0.0.0-2023-03-20T01-49-44-80e3135 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Graphql-Java | Graphql-Java | before 17.5 from 18.0 before 18.4 from 19.0 before 19.4 Version 20.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/graphql-java/graphql-java/pull/3112
- https://github.com/graphql-java/graphql-java/releases/tag/v17.5
- https://github.com/graphql-java/graphql-java/releases/tag/v18.4
- https://github.com/graphql-java/graphql-java/releases/tag/v19.4
- https://github.com/graphql-java/graphql-java/releases/tag/v20.1
- https://github.com/advisories/GHSA-p4qx-6w5p-4rj2
- https://nvd.nist.gov/vuln/detail/CVE-2023-28867