NetSight
medium6.1

CVE-2023-29014

Goobi viewer Core Reflected Cross-Site Scripting Vulnerability Using LOGID Parameter

Impact

### Impact A reflected cross-site scripting vulnerability has been identified in Goobi viewer core when evaluating the LOGID parameter. An attacker could trick a user into following a specially crafted link to a Goobi viewer installation, resulting in the execution of malicious script code in the user's browser. ### Patches The vulnerability has been fixed in version 23.03 ### Credits We would like to thank [RUS-CERT](https://cert.uni-stuttgart.de/) for reporting this issues. If you have any questions or comments about this advisory: * Email us at [support@intranda.com](mailto:support@intranda.com)

Affected packages

EcosystemPackageAffectedFixed in
mavenio.goobi.viewer:viewer-core< 23.0323.03

Affected products

VendorProductAffected versions
IntrandaGoobi Viewer Core
before 23.03

Weakness classification

References