critical9.8
CVE-2023-29216
Apache Linkis DatasourceManager module has deserialization vulnerability
Impact
In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker can use the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Users should upgrade their version of Linkis to version 1.3.2.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.linkis:linkis-datasource | < 1.3.2 | 1.3.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Linkis | through 1.3.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2023/04/10/5
- https://lists.apache.org/thread/18vv0m32oy51nzk8tbz13qdl5569y55l
- https://github.com/advisories/GHSA-rrhf-32rq-f28h
- https://nvd.nist.gov/vuln/detail/CVE-2023-29216
- https://linkis.apache.org/download/release-notes-1.3.2