high7.5
CVE-2023-30631
Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server.
Impact
Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server. The configuration option proxy.config.http.push_method_enabled didn't function. However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Traffic Server | from 8.0.0 before 8.1.7 from 9.0.0 before 9.2.1 |
| Debian | Debian Linux | Versions 10.0, 11.0, 12.0 |
| Fedoraproject | Fedora | Versions 37, 38 |
Weakness classification
References
- NVD record
- CVE.org record
- https://lists.apache.org/thread/tns2b4khyyncgs5v5p9y35pobg9z2bvs
- https://lists.debian.org/debian-lts-announce/2023/06/msg00037.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6GDCBNFDDW6ULW7CACJCPENI7BVDHM5O/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FGWXNAEEVRUZ5JG4EJAIIFC3CI7LFETV/
- https://www.debian.org/security/2023/dsa-5435
- https://lists.apache.org/thread/tns2b4khyyncgs5v5p9y35pobg9z2bvs
- https://lists.debian.org/debian-lts-announce/2023/06/msg00037.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6GDCBNFDDW6ULW7CACJCPENI7BVDHM5O/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FGWXNAEEVRUZ5JG4EJAIIFC3CI7LFETV/
- https://www.debian.org/security/2023/dsa-5435