NetSight
high7.5

CVE-2023-31058

Apache InLong Deserialization of Untrusted Data Vulnerability

Impact

Deserialization of Untrusted Data Vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0. Attackers would bypass the `autoDeserialize` option filtering by adding blanks. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7674 to solve it.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:manager-pojo>= 1.4.0, < 1.7.01.7.0
mavenorg.apache.inlong:manager-common>= 1.4.0, < 1.7.01.7.0

Affected products

VendorProductAffected versions
ApacheInlong
from 1.4.0 through 1.6.0

Weakness classification

References