NetSight
critical9.8

CVE-2023-31062

Apache InLong Improper Privilege Management vulnerability

Impact

Improper Privilege Management Vulnerabilities in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.2.0 through 1.6.0.  When the attacker has access to a valid (but unprivileged) account, the exploit can be executed using Burp Suite by sending a login request and following it with a subsequent HTTP request using the returned cookie. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 to solve it.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:manager-pojo>= 1.2.0, < 1.7.01.7.0
mavenorg.apache.inlong:manager-dao>= 1.2.0, < 1.7.01.7.0
mavenorg.apache.inlong:manager-service>= 1.2.0, < 1.7.01.7.0
mavenorg.apache.inlong:manager-web>= 1.2.0, < 1.7.01.7.0

Affected products

VendorProductAffected versions
ApacheInlong
from 1.2.0 through 1.6.0

Weakness classification

References