critical9.8
CVE-2023-31098
Apache InLong has Weak Password Requirements in Apache InLong
Impact
Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong. This issue affects Apache InLong from 1.1.0 through 1.6.0. When users change their password to a simple password (with any character or symbol), attackers can easily guess the user's password and access the account. Users are advised to upgrade to Apache InLong 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7805 to solve it.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.inlong:manager-pojo | >= 1.1.0, < 1.7.0 | 1.47.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Inlong | from 1.1.0 through 1.6.0 |