NetSight
medium6.5

CVE-2023-31101

User data exposure in Apache InLong

Impact

Insecure Default Initialization of Resource Vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.5.0 through 1.6.0. Users registered in InLong who joined later can see deleted users' data. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 to solve it.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:manager-dao>= 1.5.0, < 1.7.01.7.0
mavenorg.apache.inlong:manager-pojo>= 1.5.0, < 1.7.01.7.0
mavenorg.apache.inlong:manager-service>= 1.5.0, < 1.7.01.7.0
mavenorg.apache.inlong:manager-web>= 1.5.0, < 1.7.01.7.0

Affected products

VendorProductAffected versions
ApacheInlong
Versions 1.5.0, 1.6.0

Weakness classification

References