NetSight
high7.5

CVE-2023-31453

Apache InLong Incorrect Permission Assignment for Critical Resource Vulnerability

Impact

Incorrect Permission Assignment for Critical Resource Vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.2.0 through 1.6.0. The attacker can delete others' subscriptions, even if they are not the owner of the deleted subscription. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7949 to solve it.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:manager-service>= 1.2.0, < 1.7.01.7.0
mavenorg.apache.inlong:manager-web>= 1.2.0, < 1.7.01.7.0

Affected products

VendorProductAffected versions
ApacheInlong
from 1.2.0 through 1.6.0

Weakness classification

References