NetSight
high7.5

CVE-2023-31454

Apache InLong vulnerable to Incorrect Permission Assignment for Critical Resource

Impact

Incorrect Permission Assignment for Critical Resource Vulnerability in Apache Software Foundation Apache InLong. This issue affects Apache InLong from 1.2.0 through 1.6.0. The attacker can bind any cluster, even if he is not the cluster owner. Users are advised to upgrade to Apache InLong 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7947 to solve it.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:manager-service>= 1.2.0, < 1.7.01.7.0

Affected products

VendorProductAffected versions
ApacheInlong
from 1.2.0 through 1.6.0

Weakness classification

References