high8.8
CVE-2023-31469
Apache StreamPipes Improper Privilege Management vulnerability
Impact
A REST interface in Apache StreamPipes (versions 0.69.0 to 0.91.0) was not properly restricted to admin-only access. This allowed a non-admin user with valid login credentials to elevate privileges beyond the initially assigned roles. The issue is resolved by upgrading to StreamPipes 0.92.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.streampipes:streampipes-parent | >= 0.69.0, < 0.92.0 | 0.92.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Streampipes | from 0.69.0 through 0.91.0 |