CVE-2023-32079
Netmaker Vulnerable to Privilege Escalation From Non Admin To Admin User
Impact
### Impact A Mass assignment vulnerability was found allowing a non-admin user to escalate privileges to admin user. ### Patches Issue is patched in 0.17.1, and fixed in 0.18.6+. If Users are using 0.17.1, they should run "docker pull gravitl/netmaker:v0.17.1" and "docker-compose up -d". This will switch them to the patched users If users are using v0.18.0-0.18.5, they should upgrade to v0.18.6 or later. ### Workarounds If using 0.17.1, can just pull the latest docker image of backend and restart server. ### References Credit to Project Discovery, and in particular https://github.com/rootxharsh , https://github.com/iamnoooob, and https://github.com/projectdiscovery
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/gravitl/netmaker | < 0.17.1 | 0.17.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Netmaker | Netmaker | before 0.17.1 from 0.18.0 through 0.18.5 |