high8.1
CVE-2023-32693
Decidim Cross-site Scripting vulnerability in the external link redirections
Impact
### Impact The external link feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. ### Patches The problem was patched in [v0.27.3](https://github.com/decidim/decidim/releases/tag/v0.27.3) and [v0.26.7](https://github.com/decidim/decidim/releases/tag/v0.26.7)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | decidim-core | >= 0.27.0, < 0.27.3 | 0.27.3 |
| rubygems | decidim | >= 0.27.0, < 0.27.3 | 0.27.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Decidim | Decidim | before 0.26.7 from 0.27.0 before 0.27.3 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/decidim/decidim/releases/tag/v0.26.7
- https://github.com/decidim/decidim/releases/tag/v0.27.3
- https://github.com/decidim/decidim/security/advisories/GHSA-469h-mqg8-535r
- https://github.com/advisories/GHSA-469h-mqg8-535r
- https://nvd.nist.gov/vuln/detail/CVE-2023-32693
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-core/CVE-2023-32693.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim/CVE-2023-32693.yml