critical10.0
CVE-2023-33189
Pomerium vulnerable to Incorrect Authorization with specially crafted requests
Impact
### Impact With specially crafted requests, incorrect authorization decisions may be made by Pomerium. ### Patches We are releasing patch fixes to address this vulnerability going back to `v0.17.X`. Please upgrade to: - v0.22.2 - v0.21.4 - v0.20.1 - v0.19.2 - v0.18.1 - v0.17.4 ### For more information If you have any questions or comments about this advisory: - Open an issue in [pomerium/pomerium](https://github.com/pomerium/pomerium/issues) - Email us at [security@pomerium.com](mailto:security@pomerium.com)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/pomerium/pomerium | >= 0.22.0, < 0.22.2 | 0.22.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Pomerium | Pomerium | before 0.17.4 from 0.19.0 before 0.19.2 from 0.21.0 before 0.21.4 from 0.22.0 before 0.22.2 Versions 0.18.0, 0.20.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/pomerium/pomerium/commit/d315e683357a9b587ba9ef399a8813bcc52fdebb
- https://github.com/pomerium/pomerium/releases/tag/v0.17.4
- https://github.com/pomerium/pomerium/releases/tag/v0.18.1
- https://github.com/pomerium/pomerium/releases/tag/v0.19.2
- https://github.com/pomerium/pomerium/releases/tag/v0.20.1
- https://github.com/pomerium/pomerium/releases/tag/v0.21.4
- https://github.com/pomerium/pomerium/releases/tag/v0.22.2
- https://github.com/pomerium/pomerium/security/advisories/GHSA-pvrc-wvj2-f59p
- https://github.com/advisories/GHSA-pvrc-wvj2-f59p
- https://nvd.nist.gov/vuln/detail/CVE-2023-33189