high7.2
CVE-2023-33234
Apache Airflow CNCF Kubernetes Provider: KubernetesPodOperator RCE via connection configuration
Impact
Arbitrary code execution in Apache Airflow CNCF Kubernetes provider version 5.0.0 allows user to change xcom sidecar image and resources via Airflow connection. In order to exploit this weakness, a user would already need elevated permissions (Op or Admin) to change the connection object in this manner. Operators should upgrade to provider version 7.0.0 which has removed the vulnerability.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | apache-airflow-providers-cncf-kubernetes | >= 5.0.0, < 7.0.0 | 7.0.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Apache-Airflow-Providers-Cncf-Kubernetes | from 5.0.0 before 7.0.0 |