NetSight
critical9.8Known exploited

CVE-2023-33246

Apache RocketMQ may have remote code execution vulnerability when using update configuration function

Exploited in the wild

This vulnerability is on a Known Exploited Vulnerabilities catalogue, added 2023-09-06. Federal due date: 2023-09-27.

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Impact

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.rocketmq:rocketmq-broker>= 5.0.0, < 5.1.15.1.1
mavenorg.apache.rocketmq:rocketmq-namesrv>= 4.0.0, < 4.9.64.9.6
mavenorg.apache.rocketmq:rocketmq-controller>= 5.0.0, < 5.1.15.1.1

Affected products

VendorProductAffected versions
ApacheRocketmq
before 4.9.6
from 5.0.0 before 5.1.1

Weakness classification

References