CVE-2023-3348
Cloudflare Wrangler directory traversal vulnerability
Impact
### Impact The Wrangler command line tool (<=wrangler@3.1.0 or <=wrangler@2.20.1) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server. ### Patches Wrangler2: Upgrade to v2.20.1 or higher. Wrangler3: Upgrade to v3.1.1 or higher. ### References [Workers SDK on Github](https://github.com/cloudflare/workers-sdk) [Wrangler docs](https://developers.cloudflare.com/workers/wrangler/) [CVE-2023-3348](https://www.cve.org/CVERecord?id=CVE-2023-3348)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | wrangler | < 2.20.1 | 2.20.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Cloudflare | Wrangler | before 3.1.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://developers.cloudflare.com/workers/wrangler/
- https://github.com/cloudflare/workers-sdk
- https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-8c93-4hch-xgxp
- https://github.com/advisories/GHSA-8c93-4hch-xgxp
- https://github.com/cloudflare/workers-sdk/pull/3498
- https://github.com/cloudflare/workers-sdk/commit/fddffdf0c23d2ca56f2139a2c6bc278052594cba
- https://github.com/cloudflare/workers-sdk/releases/tag/wrangler%403.1.1
- https://nvd.nist.gov/vuln/detail/CVE-2023-3348