medium6.1
CVE-2023-33725
Broadleaf vulnerable to Cross-site Scripting
Impact
Broadleaf 5.x and 6.x (including 5.2.25-GA and 6.2.6-GA) was discovered to contain a cross-site scripting (XSS) vulnerability via a customer signup with a crafted email address. This is fixed in 6.2.7-GA.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.broadleafcommerce:broadleaf | >= 5.0.0-GA, < 6.2.7-GA | 6.2.7-GA |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Broadleafcommerce | Broadleaf Commerce | from 5.0 through 5.2.25-ga from 6.0 before 6.2.6.1-ga |