NetSight
high7.5

CVE-2023-34090

Decidim vulnerable to sensitive data disclosure

Impact

Note: added the actual report as a [comment](https://github.com/decidim/decidim/security/advisories/GHSA-jm79-9pm4-vrw9#advisory-comment-81110). ### Summary Decidim, a platform for digital citizen participation, uses a third-party library named Ransack for filtering certain database collections (e.g., public meetings). By default, this library allows filtering on all data attributes and associations. This allows an unauthenticated remote attacker to exfiltrate non-public data from the underlying database of a Decidim instance (e.g., exfiltrating data from the user table). ### Impact This issue may lead to Sensitive Data Disclosure. ### Patches The problem was patched in [v0.27.3](https://github.com/decidim/decidim/releases/tag/v0.27.3). ### Workarounds Disable or unpublish all meetings components from your application.

Affected packages

EcosystemPackageAffectedFixed in
rubygemsdecidim>= 0.27.0, < 0.27.30.27.3
rubygemsdecidim-meetings>= 0.27.0, < 0.27.30.27.3

Affected products

VendorProductAffected versions
DecidimDecidim
before 0.27.3

Weakness classification

References