NetSight
medium6.5

CVE-2023-34189

Apache InLong: General user can delete and update process

Impact

Exposure of Resource to Wrong Sphere Vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.7.0. The attacker could use general users to delete and update the process, which only the admin can operate occurrences.  Users are advised to upgrade to Apache InLong's 1.8.0 or cherry-pick https://github.com/apache/inlong/pull/8109  to solve it.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:inlong-manager>= 1.4.0, < 1.8.01.8.0

Affected products

VendorProductAffected versions
ApacheInlong
from 1.4.0 through 1.7.0

Weakness classification

References