NetSight
medium6.1

CVE-2023-3481

Critters Cross-site Scripting Vulnerability

Impact

### Impact Critters version 0.0.17-0.0.19 have an issue when parsing the HTML which leads to a potential [cross-site scripting (XSS)](https://owasp.org/www-community/attacks/xss/) bug. ### Patches The bug has been fixed in `v0.0.20`. ### Workarounds Upgrading Critters version to `>0.0.20` is the easiest fix. This is a non breaking version upgrade so we recommend all users to use `v0.0.20`.

Affected packages

EcosystemPackageAffectedFixed in
npmcritters>= 0.0.17, <= 0.0.190.0.20

Affected products

VendorProductAffected versions
GoogleCritters
from 0.0.17 through 0.0.19

Weakness classification

References