NetSight
high7.5

CVE-2023-35840

elFinder vulnerable to path traversal in LocalVolumeDriver connector

Impact

### Impact Path Traversal vulnerability in PHP LocalVolumeDriver connector. This vulnerability can be exploited by allowing untrusted users to write to the local file system. This issue was caused by incomplete validity checking of the supplied request parameters. That problem has been fixed in elFinder Version 2.1.62. ### Patches This vulnerability has been fixed in elFinder 2.1.62. Installation managers should update to the latest version as soon as possible. ### Workarounds If you cannot update for some reason, you must stop using it or prohibit writing to untrusted users.

Affected packages

EcosystemPackageAffectedFixed in
composerstudio-42/elfinder< 2.1.622.1.62

Affected products

VendorProductAffected versions
Std42Elfinder
before 2.1.62

Weakness classification

References