NetSight
medium6.6

CVE-2023-36806

Cross site scripting via input unit widget

Impact

### Impact Authenticated users can inject malicious code in widgets with units, which is then executed both in the element preview (back end) and on the website (front end). ### Patches Update to Contao 4.9.42, 4.13.28 or 5.1.10. ### Workarounds Disable login for all untrusted back end users. ### References https://contao.org/en/security-advisories/cross-site-scripting-in-widgets-with-units ### For more information If you have any questions or comments about this advisory, open an issue in [contao/contao](https://github.com/contao/contao/issues/new/choose). ### Credits Thanks to Christian Pöschl and Fabian Brenner from usd AG for reporting this vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
composercontao/core-bundle>= 4.0.0, < 4.9.424.9.42

Affected products

VendorProductAffected versions
ContaoContao
from 4.0.0 before 4.9.42
from 4.10.0 before 4.13.28
from 5.0.0 before 5.1.10

Weakness classification

References