NetSight
medium6.1

CVE-2023-3691

layui vulnerable to cross-site scripting

Impact

A vulnerability, which was classified as problematic, was found in layui up to v2.8.0-rc.16. This affects an unknown part of the component HTML Attribute Handler. The manipulation of the argument title leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.8.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-234237 was assigned to this vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
npmlayui< 2.8.02.8.0

Affected products

VendorProductAffected versions
LayuiLayui
before 2.8.0
Version 2.8.0

Weakness classification

References