CVE-2023-37480
Fides Webserver Vulnerable to Zip Bomb File Uploads
Impact
### Impact The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit a weakness in the connector template upload feature to upload a malicious zip bomb file, resulting in resource exhaustion and service unavailability for all users of the Fides webserver. This vulnerability affects Fides versions `2.11.0` through `2.15.1`. Exploitation is limited to users with elevated privileges with the `CONNECTOR_TEMPLATE_REGISTER` scope, which includes root users and users with the owner role. ### Patches The vulnerability has been patched in Fides version `2.16.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. ### Workarounds There is no known workaround to remediate this vulnerability without upgrading. If an attack occurs, the impact can be mitigated by manually or automatically restarting the affected container. ### References More information about this type of vulnerability can be found at the following links: - https://www.bamsoftware.com/hacks/zipbomb/ - https://python-security.readthedocs.io/security.html#archives-and-zip-bomb-cve-2019-9674
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | ethyca-fides | >= 2.11.0, < 2.16.0 | 2.16.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Ethyca | Fides | from 2.11.0 before 2.16.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/ethyca/fides/commit/5aea738463960d81821c11ae7ade1d627a46bf32
- https://github.com/ethyca/fides/security/advisories/GHSA-g95c-2jgm-hqc6
- https://github.com/advisories/GHSA-g95c-2jgm-hqc6
- https://github.com/ethyca/fides/releases/tag/2.16.0
- https://nvd.nist.gov/vuln/detail/CVE-2023-37480