NetSight
low2.7

CVE-2023-37481

Fides Webserver Vulnerable to SVG Bomb File Uploads

Impact

### Impact The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit this vulnerability to upload zip files containing malicious SVG bombs (similar to a billion laughs attack), causing resource exhaustion in Admin UI browser tabs and creating a persistent denial of service of the 'new connector' page (`datastore-connection/new`). This vulnerability affects Fides versions `2.11.0` through `2.15.1`. Exploitation is limited to users with elevated privileges with the `CONNECTOR_TEMPLATE_REGISTER` scope, which includes root users and users with the owner role. ### Patches The vulnerability has been patched in Fides version `2.16.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. ### Workarounds There is no known workaround to remediate this vulnerability without upgrading.

Affected packages

EcosystemPackageAffectedFixed in
pipethyca-fides>= 2.11.0, < 2.16.02.16.0

Affected products

VendorProductAffected versions
EthycaFides
from 2.11.0 before 2.16.0

Weakness classification

References