medium6.1
CVE-2023-37905
ckeditor-wordcount-plugin vulnerable to Cross-site Scripting in Source Mode of Editor
Impact
### Problem It has been discovered that the `ckeditor-wordcount-plugin` plugin for CKEditor4 is susceptible to cross-site scripting when switching to the source code mode. ### Solution Update to version 1.17.12 of the `ckeditor-wordcount-plugin` plugin. ### Credits * @sypets for reporting this finding to the TYPO3 Security Team * @ohader for fixing the issue on behalf of the TYPO3 Security Team
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | ckeditor-wordcount-plugin | <= 1.17.11 | 1.17.12 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Ckeditor-Wordcount-Plugin Project | Ckeditor-Wordcount-Plugin | before 1.17.12 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/TYPO3/typo3/security/advisories/GHSA-m8fw-p3cr-6jqc
- https://github.com/w8tcha/CKEditor-WordCount-Plugin/commit/0f03b3e5b7c1409998a13aba3a95396e6fa349d8
- https://github.com/w8tcha/CKEditor-WordCount-Plugin/commit/a4b154bdf35b3465320136fcb078f196b437c2f1
- https://github.com/w8tcha/CKEditor-WordCount-Plugin/security/advisories/GHSA-q9w4-w667-qqj4
- https://typo3.org/security/advisory/typo3-core-sa-2023-004
- https://github.com/advisories/GHSA-q9w4-w667-qqj4
- https://nvd.nist.gov/vuln/detail/CVE-2023-37905