medium4.3
CVE-2023-37906
Discourse is an open source discussion platform.
Impact
Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, a malicious user can edit a post in a topic and cause a DoS with a carefully crafted edit reason. The issue is patched in version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches. There are no known workarounds for this vulnerability.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Discourse | Discourse | before 3.0.6 Versions 1.1.0, 1.2.0, 1.3.0, 1.4.0, 1.5.0 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/discourse/discourse/commit/dcc825bda505a344eda403a1b8733f30e784034a
- https://github.com/discourse/discourse/security/advisories/GHSA-pjv6-47x6-mx7c
- https://github.com/discourse/discourse/commit/dcc825bda505a344eda403a1b8733f30e784034a
- https://github.com/discourse/discourse/security/advisories/GHSA-pjv6-47x6-mx7c