NetSight
medium6.6

CVE-2023-37941

Apache Superset Deserialization of Untrusted Data vulnerability

Impact

If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-superset>= 1.5.0, <= 2.1.02.1.1

Affected products

VendorProductAffected versions
ApacheSuperset
from 1.5.0 through 2.1.0

Weakness classification

References