critical9.8
CVE-2023-38692
CloudExplorer Lite is an open source, lightweight cloud management platform.
Impact
CloudExplorer Lite is an open source, lightweight cloud management platform. Versions prior to 1.3.1 contain a command injection vulnerability in the installation function in module management. The vulnerability has been fixed in v1.3.1. There are no known workarounds aside from upgrading.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Fit2cloud | Cloudexplorer Lite | before 1.3.1 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/blob/v1.3.0/framework/management-center/backend/src/main/java/com/fit2cloud/controller/ModuleManageController.java
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/releases/tag/v1.3.1
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-7wrc-f42m-9v5w
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/blob/v1.3.0/framework/management-center/backend/src/main/java/com/fit2cloud/controller/ModuleManageController.java
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/releases/tag/v1.3.1
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-7wrc-f42m-9v5w