NetSight
high7.5

CVE-2023-39410

Apache Avro Java SDK vulnerable to Improper Input Validation

Impact

When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Java applications using Apache Avro Java SDK up to and including 1.11.2. Users should update to apache-avro version 1.11.3 which addresses this issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.avro:avro< 1.11.31.11.3

Affected products

VendorProductAffected versions
ApacheAvro
before 1.11.3

Weakness classification

References