NetSight
medium5.9

CVE-2023-39441

Apache Airflow missing Certificate Validation

Impact

Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate.  Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow-providers-smtp< 1.3.01.3.0
pipapache-airflow-providers-imap< 3.3.03.3.0
pipapache-airflow< 2.7.02.7.0

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.7.0
ApacheApache-Airflow-Providers-Imap
before 3.3.0
ApacheApache-Airflow-Providers-Smtp
before 1.3.0

Weakness classification

References