NetSight
medium6.5

CVE-2023-39531

Sentry vulnerable to incorrect credential validation on OAuth token requests

Impact

### Impact An attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. ### Remediation - **Sentry SaaS** customers do not need to take any action. Those with the highest risk will be contacted directly by Sentry. - **Self-hosted installations** should upgrade to version 23.7.2 or higher. ### Workarounds There are no direct workarounds, but users should review applications authorized on their account (_User Settings > Authorized Applications_) and remove any that are no longer needed.

Affected packages

EcosystemPackageAffectedFixed in
pipsentry>= 10.0.0, < 23.7.223.7.2

Affected products

VendorProductAffected versions
SentrySentry
from 10.0.0 before 23.7.2

Weakness classification

References